Skip to main content

Digitisation – the ‘power’ of IoT




DS showcased the Powalert sensor at the MyBroadband conference on the 26th October 2017. IoT is the incremental next step into the optimised use of technology that was made prevalent by smart phone technology. The cost efficiencies of smart phone technologies have resulted in the deployment of a number of other generic devices that use low powered network connections as an alternative. These are the class of devices known as IoT, the Internet of Things, which were previously not networked.
The PowaINFRA range is a true IoT solution.  Powalert is a product in the PowerINFRA range. This solution expands the digital world to buildings and infrastructure that were previously mostly accessed by requiring physical connections.
The Powalert sensor, using IoT technology, provides the ability to determine power related failures within telecommunications. A last mile provider typically has multiple customers using leased lines. When an outage occurs at the customer premises, the immediate cause is typically related to either network or power. However, there is currently no out-of-band verification available to eliminate either cause as it can potentially be the power utility, the device or the interconnecting network that has failed.
This is obviously a large problem for telecommunications operators as statistics show that 80% of outages at the customer premises are related to power issues. When a utility power outage occurs, the Network Operations Centre (NOC) of a telecommunications company can usually not determine whether the cause of the outage is network related or as a result of a power outage. This is because the majority of monitoring systems deployed are unable to clearly distinguish between network and power causation as there is no “ping” power utility command. The problem for operators is that a significant number of rolling wheels call-outs are redundant.
DS’ patented solution provides the ability to distinguish power from network-based or device outages. Whilst the call-out costs associated with this may vary by type of outage, it contributes significantly to the operational budget for any organisation monitoring these devices and subsequently responding to the loss of such a device. This DS solution endeavours to optimise those associated costs by determining whether the outage is power related or not.
When the outage is not directly related to a loss of power, during a significant number of the remaining outages, technicians may power-cycle the network equipment in any case to return service. These generally relates to network hardware and software issues. As an example, the equipment from a well-known networking vendor has a bug that locks up a device after 213 days. A key feature of the Powalert is the ability to remotely recycle the power of the attached network device in the event that it loses connectivity. The Powalert device will thus be able to clear these basic faults without the requirement for a remote hands or rolling wheels visit.
The Powalert device uses a low powered wide area network protocol that is secure and encrypted. This in turn is relayed by a base station, the PowaINFRA gateway, which in turn is connected to the Vodafone M2M facility. Alternatively, if required the Powalert device can also connect directly to a Sigfox network base station.
The DS solution, as represented in the diagram above, consists of a portal that includes a service level manager (SLA) manager. This depicts the SLA uptimes of the utility and device power. Additionally, the usage in kW/h is available, as well as the power quality and the associated trending.
Increased customer satisfaction and availability levels are benefits that can be derived from accurate service level reporting. The portal reports the monthly SLA percentage uptime to an accuracy of three decimals for both the utility-side power and the device-side power. This allows the telecommunications operator to confidently exclude downtime directly attributable to power outages.
The PowaINFRA range also has sensors that are capable of monitoring and reporting on:
  • power
  • temperature,
  • fire safety,
  • presence/access
  • dam levels, as well as
  • fibre optic cable breaks.
The overall solution can be deployed not only in telecommunications but also any commercial facilities, medical facilities and equipment and data centres.
IoT device communications are secure and encrypted and are designed to transmit between known identities. These devices have not been designed with security as merely an afterthought.  IoT devices are programmed on modern principles where security is embedded into the system. IoT applications and communications are thus inherently more secure by design. As a rule, it is not that IoT devices won’t be compromised but that they are a far less likely target than the current crop of legacy devices such as wifi access points, surveillance cameras and televisions. IoT devices are thus ready to be deployed securely in multiple use cases, solving specific problems in a cost effective and efficient manner.

Popular posts from this blog

Using OPENDNS on a Mikrotik

At the office we use a Mikrotik which is connected via fibre to Cool Ideas.  We use OpenDNS as a Information Security tool.  It prevents ransomware and bots from becoming major incidents within the office.

The router is scheduled to do a daily update via script of the OpenDNS settings.  Below is the example:

:local opendnsuser "user@domain.co.za";
:local opendnspass "itsprivate";
:local opendnshost "office";

:log info "OpenDNS Update";
:local url "https://updates.opendns.com/nic/update";
/tool fetch url=($url . "\3Fhostname=$opendnshost") user=("$opendnsuser") password=("$opendnspass") mode=https dst-path=opendnsupdate.txt
:local opendnsresult [/file get opendnsupdate.txt contents];
:log info "OpenDNS: Host $opendnshost - $opendnsresult";

On board PowaINFRA gateway deployment

DS has an on board version of the PowaINFRA gateway that can be deployed on a vehicle. The gateway is powered by the 12V of the vehicle and typically installed under the dash. Additionally, the gateway has an extra sensor and metric ability of using Geo-location. The on board PowaINFRA gateway has the same capabilities as the standard PowaINFRA gateway and is compatible with the sensors in the PowaINFRA range.


Other vehicle tracking systems are typically wired and thus rely on the sensors to be connected to contacts on the main unit. No only is this a more difficult installation but it limits the number of sensors installed in a vehicle as it is not cost effective. Most vehicle installation of refrigerated trucks only have one temperature probe installed, either on the output or return vents of the cooling units. This is typically located at the front of the refrigeration trailer and the cooling varies within the trailer. Thus it is likely that the load can experience fr…