Skip to main content

The 5 myths of the Internet of Mystical Things


The Internet of Things (IoT) has created a storm of assumptions and myths. Many news articles regurgitate old themes and hyped up terms by doing a cut and paste of the term IoT into an article. In this article we will address these myths.

1.     Everything with an IP address is IoT
Shock and horror. A significant number of IoT devices do not have an IP address. They use an alternative networking protocol such as Lorawan or Sigfox where communications do not rely on a protocol designed in the 1970’s as a Do It Yourself (DIY) project for an island’s university. It is “things”, not everything!

2.     Data centres will be filled with huge quantities of IoT data.
IoT operates at a low bit rate. They complete their tasks within a couple of seconds at this low bit rate. It a Point of Sale (POS) ran at the same bit rate it would take 3 minutes for a payment. A video surveillance camera will use the same amount of data in 1 hour as an IoT sensor will use in it’s lifetime of over 20 years. To assume that new data centres will come into existence and be filled chock a block with IoT data is a stretch.

3.     IoT is a security problem.
There is a large amount of fake news being propagated by security companies. The ones who have since 1995 sold their file scanning engines as an over exaggerated security management solution. These companies state IoT is a threat as botnets target IoT. The examples they use are webcams, digital video recorders and Windows.  Refer: http://bit.ly/2zTMCHA Webcams are webcams. Always has been and always will be. They didn’t miraculously become an IoT devices because a ponytail in the marketing department of Silicon Valley decided to make it so. An IoT device has two characteristics namely low power and low bit-rate. A webcam is neither. And Windows? Give me a break, I’ve yet to find an IoT device running Windows in a production system. For the record, there has been no IoT botnet!!!

4.     IoT networks have a business case
The cheapest form of network connectivity is GSM. Most of the IoT networks out there are three to four times the price of GSM. No-one will move to these networks at that price. The obvious strategy would be to aggregate IoT sensors to a gateway to connect to a Machine to Machine network using GSM. IoT networks as a competitor to mobile network operators are hot air. They are even less viable than wifi hotspot operators.

5.     IoT is a new fad
IoT has been around for decades. An example is vehicle tracking devices that have been in existence for decades. These devices are GPS location sensors that communicate a vehicle's position and use GPRS as the means of communication. GPRS is a low bit rate mobile based protocol that was the first entry by mobile operators into data. It is still used today for low bit rate applications.

Post comments about your own ideas of IoT myths.

Popular posts from this blog

Using OPENDNS on a Mikrotik

At the office we use a Mikrotik which is connected via fibre to Cool Ideas.  We use OpenDNS as a Information Security tool.  It prevents ransomware and bots from becoming major incidents within the office.

The router is scheduled to do a daily update via script of the OpenDNS settings.  Below is the example:

:local opendnsuser "user@domain.co.za";
:local opendnspass "itsprivate";
:local opendnshost "office";

:log info "OpenDNS Update";
:local url "https://updates.opendns.com/nic/update";
/tool fetch url=($url . "\3Fhostname=$opendnshost") user=("$opendnsuser") password=("$opendnspass") mode=https dst-path=opendnsupdate.txt
:local opendnsresult [/file get opendnsupdate.txt contents];
:log info "OpenDNS: Host $opendnshost - $opendnsresult";

On board PowaINFRA gateway deployment

DS has an on board version of the PowaINFRA gateway that can be deployed on a vehicle. The gateway is powered by the 12V of the vehicle and typically installed under the dash. Additionally, the gateway has an extra sensor and metric ability of using Geo-location. The on board PowaINFRA gateway has the same capabilities as the standard PowaINFRA gateway and is compatible with the sensors in the PowaINFRA range.


Other vehicle tracking systems are typically wired and thus rely on the sensors to be connected to contacts on the main unit. No only is this a more difficult installation but it limits the number of sensors installed in a vehicle as it is not cost effective. Most vehicle installation of refrigerated trucks only have one temperature probe installed, either on the output or return vents of the cooling units. This is typically located at the front of the refrigeration trailer and the cooling varies within the trailer. Thus it is likely that the load can experience fr…

Digitisation – the ‘power’ of IoT

DS showcased the Powalert sensor at the MyBroadband conference on the 26th October 2017. IoT is the incremental next step into the optimised use of technology that was made prevalent by smart phone technology. The cost efficiencies of smart phone technologies have resulted in the deployment of a number of other generic devices that use low powered network connections as an alternative. These are the class of devices known as IoT, the Internet of Things, which were previously not networked. The PowaINFRA range is a true IoT solution.  Powalert is a product in the PowerINFRA range. This solution expands the digital world to buildings and infrastructure that were previously mostly accessed by requiring physical connections. The Powalert sensor, using IoT technology, provides the ability to determine power related failures within telecommunications. A last mile provider typically has multiple customers using leased lines. When an outage occurs at the customer premises, the…